OpenRoads Designer CONNECT Edition SDK Help

GetPartialByDistances(Double, Double, Double) Method

Returns a partial element from start distance to end distance

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearElement GetPartialByDistances(double startDistance,double endDistance,double ptToPtTolerance)

Parameters

SettingDescription
   Start distance along the element
   End distance along the element
   Point to point tolerance used to perform the operation.

Return Value

LinearElement The partial element

Remarks

To obtain the point to point tolerance that is passed as parameter calculation will be performed with a precision equal to ptToPtTolerance/100

See Also